Spanning Sync Ready for Snow Leopard

Brian  

Spanning Sync 3 is fully compatible with the to-be-released-Friday Mac OS X 10.6, a.k.a. Snow Leopard.

Picture 6.png

From SS Blog: “Spanning Sync 3 is fully compatible with Snow Leopard and takes full advantage of its support for 64-bit processing. (And for those of you with an eye for the technical details, the Spanning Sync pref pane is now garbage-collected.)”

Full details here.

Save $5, then make $5 (or more than $5) using coupon code D8BYCM

Be the first to leave a comment

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.