Publishing to a Single SWF from Captivate

Brian  

If you perform full motion capture in Captivate (happens automatically when you drag your mouse), it will create multiple SWF files in your project directory. A work around I learned yesterday from RJ is below:

  1. Record your Captivate movie as you normally would, including drag and drop.
  2. Publish your Captivate movie as SWF output (this publishes the main movie plus individual full motion SWFs)
  3. In Captivate, go to the Full Motion slides and delete the full motion screen, then insert an animation and navigate to and select your full motion swf to insert.

  4. Repeat step 3 for all full motion slides
  5. Publish your Captivate movie to SWF output. (optionally, you can also turn off the skin when you publish – I created a “no-skin” skin)
  6. In your published folder, you can now delete the full motion swfs and the skin swf if you want. Your published SWF will contain the full motion swfs you inserted as animations with no loss of quality.

Let me know if you have questions and/or comments about this.

13 thoughts on “Publishing to a Single SWF from Captivate

  1. If you turn off the Show Borders on the skin it publishes to a single file and still has the playback controls available.

  2. Your a Godsend! your article was the only one that worked for me! I was able to create a movie within a PDF (acrobat 8) with one SWF that contained full motion slides and captions!

    1. No problem – glad I could be of assistance – though I cannot take full credit – just sharing what I learned from others. Great stuff though. It was a great fix for me as well.

      1. Brian I did what you said and if I delete the full motion swfs, my main swf does not display the separate full motion swfs? Do you know what I am doing wrong

    1. Greg – not sure why you’re losing audio – I’m assuming you followed the steps exactly? Contact me (use the form or reply to this comment) and we can discuss further.

  3. Hi Brian,
    I use both Adobe Connect and Captivate. In Captivate 3, I could import a powerpoint file, loop it and add looping audio. I would publish it as a SWF file and upload the SWF to a Connect share pod, creating a nifty looping virtual lobby for people to see before my webinar started. Now that I have Captivate 5, this process doesn’t seem to work anymore. The SWF file appears to upload to Connect, but then flashes and buzzes until I stop sharing. I wonder if there are settings I need to change in Captivate 5 for it to work? Any help would be much appreciated.

    thanks,
    Jeanne

    1. Hi Jeanne – thanks for the comment. I’ve just started using Captivate 5 myself. We don’t use Connect, so I’m not sure I can help you there. You should be able to generate the same looping effect. Have you tried publishing to Adobe Presenter, then looping it? Also, you might ask RJ Jacquez (@rjacquez) or Steve Howard (@stevehoward999).

  4. Brian,
    thanks for the suggestions. A Flash-savvy friend tells me Captivate 5 does something with A03 and A02 that doesn’t work with the current version of Connect. I decided to back to Captivate 3 for this particular task until Adobe resolves the compatibility problem (i.e., upgrades Connect). Thanks again…

Leave a Reply to Brian Cancel reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.